Delay in Report Card Generation

Incident Report for Cardiogram

Resolved

We are pleased to announce that the issue with delayed Report Card generation in the Cardiogram app has been successfully resolved. Our team has worked diligently to ensure that all functionalities are fully restored and performing optimally.

If your Report Card has not yet been updated, please follow these steps to manually trigger a regeneration:


- Open the Cardiogram app.
- Go to the menu in the top left corner and tap on "Edit Profile."
- Verify that your height, weight, and age are correctly entered. If any updates are needed, make the changes.
- Tap 'Save' to confirm the information.
- Following these steps will force your Report Card to be generated within 72 hours.


Thank you for your patience and cooperation as we worked through this issue. We understand the importance of having access to your health insights in a timely manner and are committed to ensuring the reliability of our services.

For any further assistance or inquiries, please feel free to contact our support team at hello@cardiogram.com

Thank you for being a valued member of the Cardiogram community and for your trust in our service.
Posted Mar 13, 2025 - 13:46 PDT

Update

We continue to monitor the recent fix deployed to address the delays in Report Card generation, which is performing as expected. We are optimistic about the results and are progressing with the batch processing to ensure all users receive their updated Report Cards.

To facilitate the regeneration of your Report Card, please verify that your height, weight, and age are correctly entered in the app. Updating this information will trigger the regeneration process for your profile, which may expedite the update of your health insights. To do this go to the menu in the top left of Cardiogram. Tap on "Edit Profile". Verify your biometric data, then tap on save.

Check your profile details in the Cardiogram app and make any necessary updates to your personal information. Once updated, your Report Card will automatically be retriggered and updated as part of our ongoing batch processing.

We appreciate your continued patience as we finalize the resolution. We understand the importance of timely and accurate health data and are committed to fully restoring this service for all our users.
Posted Mar 10, 2025 - 09:22 PDT

Monitoring

We are pleased to report that the fix deployed to address the delay in Report Card generation is working effectively. However, due to the current workload and the necessity to ensure accuracy and reliability, Report Cards are being generated in batches.

As a result, it may take up to an additional 72 hours for all users to see their updated Report Cards. We are making every effort to process these as quickly as possible and appreciate your continued patience.

Please continue to check your Cardiogram app periodically over the next 72 hours. There is no action required from your side; your Report Card will update automatically once the batch processing reaches your account.

We thank you for your continued patience and understanding during this time. We are committed to providing you with reliable and timely health insights.
Posted Mar 06, 2025 - 09:58 PST

Identified

Our engineering team has implemented a fix for the delay in Report Card generation within the Cardiogram app. The fix is currently being deployed, and we are monitoring its effectiveness.

Due to the backlog and the significant workload, the scores may take up to 72 hours to fully update and reflect accurately in your profiles. We appreciate your patience as we work through the data to ensure that each report card is generated with the highest accuracy and detail.

There is no action required from users. Your Report Cards will automatically update once the processing is complete. Please allow up to 72 hours for your report to be updated. If your report still appears outdated after this period, feel free to contact our support team.

We apologize for any inconvenience this delay may cause and value your understanding as we strive to restore and ensure optimal functionality.

Thank you for your understanding and patience and for your continued trust in Cardiogram.
Posted Mar 04, 2025 - 10:02 PST

Investigating

We are currently addressing an issue where some users are experiencing delays in the generation of their Report Cards within the Cardiogram app. Please be assured that the data integrity for generating these reports remains unaffected, and all user data is secure and accurate.

Our engineering team is diligently working to identify and resolve the cause of this delay. We anticipate a swift resolution and will ensure that once the issue is resolved, a new and accurate score will be promptly generated for affected users.

We will provide an update as soon as more information becomes available or once the issue has been resolved. Please check this page regularly for the latest status.

We apologize for any inconvenience this delay may cause. We are committed to providing reliable and timely health insights. Your patience and understanding during this time are greatly appreciated.

Thank you for your continued trust in Cardiogram.
Posted Feb 25, 2025 - 10:05 PST
This incident affected: Cardiogram App.