Unable to access Cardiogram
Incident Report for Cardiogram
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 16:40 PDT
Investigating
Cardiogram is currently experiencing technical difficulties, and some users may be unable to access the app at this time. Our team is actively working to resolve the issue and restore full functionality as soon as possible.

We understand the importance of your health data and apologize for any inconvenience this may cause. Please rest assured that all data is secure, and we are committed to providing a seamless user experience.

Thank you for your patience and understanding as we work to resolve this matter promptly. We will continue to provide updates on our progress. Stay tuned for further announcements.
Posted Mar 18, 2024 - 12:57 PDT
This incident affected: Cardiogram App.